Announcement

Collapse
No announcement yet.

Bun is need help (Keyboard drivers windows 7)

Collapse
X
Collapse
Who has read this thread:
  • Filter
  • Time
  • Show
Clear All
new posts

    Bun is need help (Keyboard drivers windows 7)

    I recently bought this keyboard, plugged it in and everything seemed to work fine. Hopped into a game, keyboard suddenly stops working for a few seconds, wait and it starts up again. Realized this was happening a lot. then I noticed it was messing with my mouse because it started locking up on me as wel, though not nearly as bad as the keyboard itself was. I also noticed that whenever my mouse and keyboard froze up I lost any sort of sound coming from my headset. Pretty much anything that was plugged into a USB would stop working and occasionally if i tried to run a game they would completely crash to the point where I had to restart my computer just to get anything that's connected to it to actually fucking work.

    Thought it might be a driver issue so I went into device manager to look for drivers, drivers could not be found. turned on Microsoft updates, downloaded all of my updates, but the problem didn't go away. Tried device manager again, no drivers found. Looked up the manufacturer, couldn't find their website. I'm basically stuck with no idea what drivers to use or where to get them. does anyone know how to fix this or should i just send it back and get my money back?

    #2
    Can you show us your Device manager with all the sections that have something with USB being plugged in in them expanded?
    Born in the light.
    Molded in the dark
    .

    Never Forget,
    Keep Fighting.
    –Don't Forget.
    Always, somewhere,
    someone is fighting for you.
    –As long as you remember her,
    you are not alone.

    Comment


      #3




      That's what it looks like with the keyboard plugged in. I tried resolving the other USB issues but that just turned into a waste of time since windows could not find any driver updates for that. All my other USB ports including my old keyboard still work fine so long as the new one isn't plugged in.

      Comment


        #4
        That's weird. Does this only happen when the keyboard is plugged in? Found this for the first one. https://www.intel.com/content/www/us...-software.html

        As for the second one, did you recently change motherboards it something like that? Can you go to the manufacturer website and see if they offer any drivers that fix the issue?

        Sent from my Nexus 5X using Tapatalk
        Born in the light.
        Molded in the dark
        .

        Never Forget,
        Keep Fighting.
        –Don't Forget.
        Always, somewhere,
        someone is fighting for you.
        –As long as you remember her,
        you are not alone.

        Comment


          #5
          https://www.newegg.com/Product/Produ...82E16813131837

          Been using this motherboard for the past 4 years ever sine my computer was first made.

          Also I'm looking for the right download button. Is it one of these?

          Comment


            #6
            For the Intel stuff, just download one for your system. For your motherboard, found this but couldn't find anything for the USB issue there. https://www.asus.com/us/Motherboards...Desk_Download/
            Born in the light.
            Molded in the dark
            .

            Never Forget,
            Keep Fighting.
            –Don't Forget.
            Always, somewhere,
            someone is fighting for you.
            –As long as you remember her,
            you are not alone.

            Comment


              #7
              https://imgur.com/MsX2AaE
              I would always read recent reviews before purchasing a product. It looks like there are others that have run into issues with the particular model you have bought. It can also be 50/50 with any brand that isn't well known, sadly. I suppose you can do what that guy did and call to get the drivers or you can see if they can exchange it.

              Comment


                #8
                I've noticed this too. different people posting this problem that's marked as "answered" when the only answers are people saying "Oh well I don't have this problem." Anyway I can't seem to get it to work so I'm probably gonna send it back and get another one. Thanks for your help guys.

                Comment

                Working...
                X